Adding A Bleed to Print/Cut File Setup

in Adobe lllustrator

The guide outlines the procedures | use to create a bleed on Print/Cut files. There are a
hundred different ways to skin this cat - | have found these to be the fastest methods for
me. You may need to experiment to find a workflow that is right for you.

Use these methods when a white contour around an object is not desired.
There are 2 examples in this guide.

1) The Correct Way to set up a bleed - best for when you will need to reuse a file in the
future

2) The Quick and Dirty Way to setup a bleed - good for one-off jobs that need a quick fix

The CORRECT WAY: 1) Open your file/artwork.
Inspect for possible issues.

This file was supplied by a customer. For the purposes of this tutorial, we will change
the outline fill to black to setup a bleeed.

It appears it was not originally created in Adobe lllustrator. This means we need to
check for issues that may cause any errors when we send the file to the RIP.

ADDING A BLEED TO PRINT/CUT FILE SETUP IN ADOBE ILLUSTRATOR




Adding A Bleed to Print/Cut File Setup
in Adobe lllustrator

K for demo

~
0404-566

\ J
- J/

Background Color: White
Graphic/Text color(s): Black
Size: 3"x 3"

- . . 1 Artboard 1
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1-a) Check for Clipping Mask

When | select the outer rounded rectangle in the artwork, the stroke which appears to
be black - does not have a stroke color in lllustrator.

ADDING A BLEED TO PRINT/CUT FILE SETUP IN ADOBE ILLUSTRATOR




Adding A Bleed to Print/Cut File Setup

in Adobe lllustrator

This probably means that our artwork has a clipping mask, which is known to cause
many issues with Roland Versaworks.
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1-b) Switch to Outline Mode

It helps to look at the artwork in Outline Mode. Any clipping masks contained in the file
will be visible once you switch to outline view.

To switch to Outline view: In the top nav, click View > Outline
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1-c) Inspect artwork

After switching to outline view, we can now see that there are two rectangle paths that
do not show up in the regular view. These are clipping masks and will need to be
removed.

**NOTE: This is not always the case. Sometimes it could just be a path that did not
have a stroke or fill selected.
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2) Remove Clipping Masks

To remove clipping masks from a file, select all the artwork (Ctrl+A, On Mac:
Cmd+A)
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2-a) Release Clipping Masks
With artwork selected, in the top nav goto Object > Clipping Mask > Release

You may have to do this several times to release all the clipping masks on a particular
file.
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2-b) Delete the paths
After releasing the clipping mask this is our result.

Delete the extra paths from the file.
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3) Unexpected Issue: Color Mode

Our next step is to add a black fill to the outer rectangle. At this point, | realized that the
file was in the wrong color mode. The file was in RGB mode - we need it to be in CMYK
so that our colors will print correctly and predictably when we send the file to the RIP.

This is typically something you would want to check at the beginning of working with a
file.

To change the color mode to CMYK, in the top nav go to File > Document Color
Mode > CMYK Color

ADDING A BLEED TO PRINT/CUT FILE SETUP IN ADOBE ILLUSTRATOR



Adding A Bleed to Print/Cut File Setup

in Adobe lllustrator

. Mustrator GO0 Edit Object Type Select Effect View Window

HEN
{raEM
20 Uniorm [l —— ssic [l
>
O

EW

#*S
{+3S
NFHS

N{rEEsS

F12

3-a) Convert color swatch to CMYK

Even after changing our document color mode, sometimes lllustrator will keep an
object's color swatch in RGB mode.

To change this:
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In the Color panel, click the dropdown at the top right hand and select CMYK
option
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3-b) Fix any color mismatches
Add your black fill to the outer rectangle.

Once you add the fill, notice that the stroke and the fill appear to be different colors of
black. This is because of our incorrect color mode.

You'll want to change the blacks to the same color values to ensure they print correctly.
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3-c) Select the rich black object

There is a quick way to fix all the color mismatches. In this example, | will change all the
rich blacks to a 100% K black.

Select one of the objects with a rich black stroke.
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3-d) Select objects with the same stroke color
In the top nav, go to Select > Same > Stroke Color

This command will select all objects in the file with the same stroke color as the
selected object.
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3-e) Change the stroke color to 100% K

With all the objects selected, change the stroke color to 100% K.
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This will give us the uniform blacks that we're after.

Stroke Gradient 3 Transparency

Normal ¥ Opadty: -

3-f) Repeat the above process for objects with a rich black fill

The process above should be repeated to remove any objects with a rich black fill as
well.

Use the Select > Same > Fill Color command to select objects with the same fill
color.
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Once selected change the fill of those objects to 100% K as well
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4) Add CutContour

Select the outer rectangle that you wish to use as a cutline. Add the CutContour
spot color as the stroke.

If you do not already have the CutContour spot color setup:

ADDING A BLEED TO PRINT/CUT FILE SETUP IN ADOBE ILLUSTRATOR



Adding A Bleed to Print/Cut File Setup

in Adobe lllustrator

Click the dropdown in the top right hand of the Color panel. Select Create New Swatch
and under Swatch Name: Enter "CutContour". Set Color Type to Spot Color and set the
color values to 100% M. Then click OK.

New Swatch

swatch Name:

Color Type: Spot Color

Color Mode: | CMYK
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Background Color: White
Graphic/Text color(s): Black
Size: 3" x 3"
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5) Add Bleed

Next we will add our bleed to the file. **NOTE - This particular file has two outer objects
- one for the fill and one for the stroke. Other files may have the stroke and fill on the
same object.

Select the outer rectangle with the black fill.
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5-a) Offset Path
| use the Offset Path tool to add bleeds to my files.

With the black fill rectangle selected, go to Object > Path > Offset Path
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5-b) Offset Path Dialog
In the offset path dialog, enter the settings you wish to use.

For smaller decals, | typically use .125 in as the offset value. This is usually
enough to ensure mask enough cutter registration errors.

For larger decals, | may go to .25 in as a way to be safe.

Adjust the Joins setting as you see fit. For this example the cutline is a simple rounded
rectangle, so a Miter join will be fine.

| would not change the Miter limit setting for this example.

Click OK
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5-c) The Result

Once | use the Offset Path command, while the result is still selected | will do two
commands.

Edit > Cut (Ctrl+X; Mac Cmd+X)
Edit > Paste in Back (Ctrl+B: Mac Cmd+B)

| do this because if you deselect the result, lllustrator will group the original path and
the new offset path together. This is a minor inconvience and typically will only cause
you gried on complex files.

Before sending to the RIP, delete the text below the decal.
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6) Save the file and send to RIP

At this point, the file should be ready to rock. Save it out and send it to your RIP.
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QUICK AND DIRTY: 1) Change Document Color
Mode

This workflow would be a quick method for preparing this file with a bleed.

After working through this file for the first method, | know | will need to change the
Document Color Mode.

After opening the file, goto File > Document Color Mode > CMYK Color
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2) Delete un-needed elements

Choose the Group Selection Tool.

This tool allows you to select individual objects in a group, without selecting the whole
group.

aup Selection Tool
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2-a) Select and delete outer box and text elements.

This file does have an outer bounding box. Be sure to select and delete it along with the
text.

L —

Backaground Color: White

Graphic/Text color(s): Black
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3) Convert artwork colors to grayscale

Select all the artwork that remains. In the top nav, Select > All or Ctr+A, Mac
Cmd+A

With artwork selected, go to Edit > Edit Colors > Convert to Grayscale

This will convert all my blacks to grayscale, and | will not have the rich black issue.
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4) Add the bleed

Select the rounded rectangle with the white fill.
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4-a) Copy the rectangle

Edit > Copy or Ctrl+C; Mac Cmd+C
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4-b) Change the rectangle fill to black

In the color panel, change the fill of the rectangle to black.
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4-c) Offset Path

With the rectangle still selected, use the Offset Path tool

Object > Path > Offset Path
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4-d) Offset Path Dialog

Again we will use .125 in for the Offset.

Click OK

Offset Path

Lol 0.125 in

Joins: | Miter

.
miter limie; T

[+ Preview Cancel

Swatches Brushes Symbols

5) Rasterize the Artwork

Select all the artwork once again.
Select > All or Ctrl+A; Mac Cmd+A

Then use the Rasterize command
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5-a) Rasterize Dialog

For this example, the default settings are sufficient. | would want to stay with a
resolution of 300ppi to ensure | get a high quality print.

Rasterize

Color Model: CMYK

Resolution: High (300 ppi)

Background
* White

Transparent

Options
Anti-aliasing: Art Optimized (Supersampling)

Create Clipping Mask

Add: = (I Around Object

“ Preserve spot colors

5-b) Result

Because of the clipping masks contained in the artwork, you can see it that the
Rasterize command has made our image significantly large than it should.
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To keep this from causing size issues in our RIP we will change the artboard size and
save the file as a PDF.
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5-c) Resize the Artboard

Using the Artboard tool, resize the Artboard to the edges of our bleed.
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6) Add CutContour

Paste our original rounded rectangle back into the file. Use the Paste in Front
command

ADDING A BLEED TO PRINT/CUT FILE SETUP IN ADOBE ILLUSTRATOR




Adding A Bleed to Print/Cut File Setup

in Adobe lllustrator

Edit > Paste In Front
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6-a) Adding CutContour stroke
Remove the fill from the rectangle, and add the CutContour spot color stroke.

New Swatch

Swatch Name:
Color Type:| Spot Color v

TEHANDART

s ANEFEF

[\

Lz
:‘:\
s
7
-
=
w,
j»

B,
i
W,
6
e

nn

e

ADDING A BLEED TO PRINT/CUT FILE SETUP IN ADOBE ILLUSTRATOR



Adding A Bleed to Print/Cut File Setup

in Adobe lllustrator

6-b) Result

The result should look something similar to the screenshot below. Our file consists of a
single image and a CutContour path.
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7) Save the file as PDF

Go ahead and save the file at this point.
It is important to save it as PDF instead of EPS.

The PDF format will base the size off of the actual artboard size.
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The EPS format will base the size off of the actual artwork.

Save Adobe PDF

Adobe PDF Preset: [lllustrator Default]
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Ad P d llustrator, or when you need to place it in a layout application such as
5&::::: InDesign, or when the final use of the file is unknown.

Summary!
Options

~ Preserve lllustrator Editing Capabilities
“ Embed Page Thumbnails
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View PDF after Saving

~ Create Acrobat Layers from Top-Level Layers

Cancel Save PDF
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