Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EFI Vutek GS3250 LX Pro Serial Server no power

Discussion in 'Miscellaneous Printers' started by M@CK, Apr 21, 2020.

  1. M@CK

    M@CK Member

    118
    0
    16
    Oct 30, 2007
    Montreal
    Morning all you Vutek pros out there, I'm having an issue with my serial server not getting power, the tech seams to think that the unit is dead, EFI is asking 6500$ for what I see is basically a hub or switch ... that I can get on EBAY for 100$... So my question is this, is this part special ? special firmware or special programming in it ?


    Kindest Regards y'all !
     
    Tags:
  2. WYLDGFI

    WYLDGFI Merchant Member

    1,425
    195
    63
    Oct 27, 2006
    Linden, NJ
    From my experience with Vutek over the years, it typically IS proprietary. Though there are parts outlets that carry used or refurbished items. May want to google and shop around.
     
  3. netsol

    netsol Very Active Member

    1,015
    150
    63
    Apr 26, 2016
    englishtown, nj
    if i am following you, you have a vutek ethernet to serial device that IS CERTAINLY DEAD, by your own description

    never touched a vutek, but have done quite a bit with digi equipment.
    can you post a mdl and serial # ?

    a picture of what you have wouldn't hurt either
    wyldgfi and i are both in new jersey, so, happy to help but

    it won't be as speedy as being in front of the equipment
     
  4. netsol

    netsol Very Active Member

    1,015
    150
    63
    Apr 26, 2016
    englishtown, nj
    not to get ahead of myself, bupt did we check power supply voltages?
    is power supply seperate? like on a laptop?
     
  5. WYLDGFI

    WYLDGFI Merchant Member

    1,425
    195
    63
    Oct 27, 2006
    Linden, NJ
    http://www.primeprinterservice.com

    These guys are ex refi techs and have parts and such. Might be able to assist as well. I dealt with them in the past and are a standup outfit.
     
  6. M@CK

    M@CK Member

    118
    0
    16
    Oct 30, 2007
    Montreal
    Hey guys, thanks for all the help.

    @ netsol, first thing I did was check the voltage, and it was good.
    Someone reached out to me and sold me a genuine EFI part at a steep discount, for a similar printer they don't have anymore, so I managed to get back up and running.

    @ WYLDGFI thanks for the info, I will definitely keep there contacts on hand.

    FYI: I don't think this part is "proprietary", but in it self is a special part from that part manufacturer, after a bit more research I fond out that the MEI appellation for the part stands for Multiple Electrical Interface and that the Print Console programs it at the first start, So as long that I used a part that was MEI in that same family bracket, my thinking was that its was ok. Guess I will never have find out ¯\_(ツ)_/¯
     
  7. netsol

    netsol Very Active Member

    1,015
    150
    63
    Apr 26, 2016
    englishtown, nj
    i like to see a happy ending
     
Loading...

Share This Page

 


Loading...