Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Falcoln Outdoor No ink to head

Discussion in 'Mutoh' started by bgow, Apr 18, 2013.

  1. bgow

    bgow New Member

    8
    0
    0
    Oct 4, 2012
    Fustrated tried cleaning heads with foam swaps and capping station, tried power cleaning and cleaning. No ink in dampers except blue which prints faint. How to flush or clean lines? or other suggestions. Falcon Mutoh outdoor solvent 48"
     
    Tags:
  2. Mrose

    Mrose New Member

    15
    0
    0
    Apr 11, 2013
    I dont have a Falcon, I have a Roland that also has the dampers. I have had to disconnect the ink line and use a syringe to pull the ink to the head. Just a thought.
     
  3. SlightlyChilled

    SlightlyChilled Very Active Member

    1,270
    0
    36
    Dec 19, 2009
    Hell
    Can you pull ink to the dampers? Not from the capping station but the bottom of the dampers. Also what did you changes to make this happen. Is your station new or old. If you were losing nozzles then the capping station might be on the way out or the pump. Also the lines in the pump might have a hole in them. I had a small one once and it messed me up bad.

    Dampers might not have a good seal carts might not be set right ink line could be cracked. I could go on but this should hold you over.
     
Loading...

Share This Page

 


Loading...