Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GBC laninator - power light on, doesn't run...

Discussion in 'Miscellaneous Hardware' started by iSign, Dec 30, 2009.

  1. iSign

    iSign Major Contributor

    13,027
    31
    48
    Nov 29, 2003
    Kahului, Maui
    anyone know if there are fuses hidden somewhere?
    My manual is no help, but there are a bunch of 250V fuses in with it... some 6.3 Amp, and some 2 Amp... but I've had it 4 years and don't recall needing one... I've looked all over 3 times... but there is a half laminated "rush" print in there, & I don't want to start unscrewing access panels wildly, if i might find someone who knows where i should be looking
     
    Tags:
  2. jgolo

    jgolo Member

    96
    0
    0
    Oct 19, 2005
    By chance you did not push one of the emergency stop buttons in or is there something small blocking the light beam? Simple, but could happen!
     
  3. GAC05

    GAC05 Major Contributor

    5,987
    819
    113
    Dec 27, 2005
    Guam USA
    Can't be of any help here Doug, don't own one of those.
    I hope you get it sorted out, I couldn't help but notice that I have the exact same problem with some of my employees. At least I think the light is on.

    Happy new year to you.

    wayne k
    guam usa
     
  4. iSign

    iSign Major Contributor

    13,027
    31
    48
    Nov 29, 2003
    Kahului, Maui
    well, it's sorta still a mystery, but sorta not... it happened when showing a new prospective employee how to run it, and I did two myself, showing him how the foot switch is good for starting off slow, but then you can reach over to the "run" button & dial up a faster speed...

    I gues I usually let off the foot switch right when I hit run, but I didn't mention that... anyway, right when he hit run, with his foot still on the foot switch... it just stopped...

    I couldn't figure it out but i think the cosmic intent here was to encourage what took place next.. the guy had failed to be able to do anything i needed all day, & worse yet, he didn't even know he was messing up... so I sent him home because i have some serious deadline pressure & it is really not the time for me to be training unless someone see's it once, & takes over and gets things done...


    Once he was gone, I checked the emergency stop buttons 3 times, removed, replaces & generally rattled both the infeed & the hold down bars that have electronic sensors in them... did that about three times too...


    ...but i just went a rattled the hold down bar real hard & presto... crisis over (except the deadline)

    gotta go laminate!
     
  5. astro8

    astro8 Active Member

    778
    17
    18
    May 23, 2009
    Sydney, Australia
    I've had 2 laminators ..Applikators that are temperamental like that...sometimes have to rattle and wait and next thing presto it works. I'll know what to do now if the GBC starts acting up. Just loose connections somewhere.
     
Loading...
Similar Threads - GBC laninator power
  1. bayviewsignworks
    Replies:
    4
    Views:
    841

Share This Page

 


Loading...