Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help Needed, New Heads Going Bad

Discussion in 'Roland' started by hanother, Sep 14, 2012.

  1. hanother

    hanother New Member

    7
    0
    0
    Mar 29, 2011
    Hello, I'm hoping I can get some help/advise on my problem. My machine is an SP300V. My problem seemed to start when I switched over to Triangle Ink but may be a coincidence. The black started firing like you see in the picture. The heads were five years old at this point so I replaced both heads with "bargain" heads I found thru an ebay search. They are Roland brand heads with head rank priced @ $800.00 a piece. Good deal? maybe, maybe not. After installing, head ranking and aligning the new heads we were back to new condition. All good... I thought but after three months the black returned to how it looks here. I replaced the head again and three months or so again we are back here again. My question is has anyone had a problem with these bargain heads or a problem with black triangle ink shortening the life of the black side of the print head?

    Is it possible that something with the board is causing this side of the head to fail? I did have an issue with a blown fuse & transistor on that head.

    Considering replacing head again and going back to Roland Ink.
     

    Attached Files:

    Last edited by a moderator: Sep 15, 2012
    Tags:
  2. FrankW

    FrankW Active Member

    977
    34
    28
    Oct 19, 2008
    Switzerland
    I would try to replace the head cable for black, it's cheaper than replacing a head, and could be a reason too.
     
  3. hanother

    hanother New Member

    7
    0
    0
    Mar 29, 2011
    Thank you for your reply, all head cables were replaced.
     
  4. kffernandez

    kffernandez Member

    311
    1
    18
    Jun 26, 2010
    Philippines
    that black head looks like the time i ran mine through an ultrasonic machine. actually, it also happened when i pushed too hard with my cleaning solution as well. in other words, in those cases i think the membranes inside the head were messed up by the pressure.

    edit: it could also be that i messed up some of the electronics in the process.

    kelly
     
  5. hanother

    hanother New Member

    7
    0
    0
    Mar 29, 2011
    Thanks for the info Kelly, have you had any experience using the heads for sale on ebay for around $800.00?

    Any experience using Triangle inks?
     
  6. Rafael_Tech

    Rafael_Tech New Member

    9
    0
    0
    Aug 3, 2012
    Your problem is definitely the ink. I would consider changing ink to at least RedGiant brand but you'll have to flush the lines and print heads to avoid clogging problems, using cleaning cartridges.
     
Loading...

Share This Page

 


Loading...