Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with Mutoh vj1624

Discussion in 'Mutoh' started by Austin627, Aug 25, 2020.

  1. Austin627

    Austin627 New Member

    3
    0
    1
    Aug 25, 2020
    San Antonio
    Hi I'm having trouble with my printer and looking to see if someone may be able to help its a mutoh vj1624. The printer recently stopped printing cyan so we took the head out to try to flush it out. After reinstalling the head in the printer it then wouldn't print at all we discovered one of the ribbon cables was frayed and possibly caused a short it blew out a fuse on the main board replacing it didn't help we had a friend come out and take a look at it and he believed it had also had ruined the head so we put a new head in but still nothing it prints as it normally would but does not lay any ink down. It has a brand new maintenance station and you can see the ink running through the lines. If any one has any suggestions to get it to lay down ink let me know
     
  2. FatCat

    FatCat Very Active Member

    2,021
    204
    63
    Feb 12, 2007
    Columbus, Ohio
    Lots of things could be going on here, so I'll offer a few things to try...

    If ink is flowing into the waste lines then it is more likely an electrical issue, which could be numerous things. I would replace the ribbon cables if you haven't already, pay very close attention that they are seated correctly and making good contact and there is no ink on the contacts. Getting the cable seated correctly is critical and they can be a pain sometimes.

    You say you blew a fuse on the mainboard? If there was a short and it was really bad, it could've killed the mainboard, this is the danger of shorts...sometimes you can't see everything it's damaged.

    Testing with a new head, and new ribbon cable you should be able to rule out everything but the board itself...but if it still doesn't work I would be thinking its the board...
     
  3. Austin627

    Austin627 New Member

    3
    0
    1
    Aug 25, 2020
    San Antonio
    FatCatFatCat thanks for the reply it has all new cables and is still not printing before i ordered the new mainboard i was looking through all the fuses i can find all of them except f2 and f5 after a little research i found f2 usually is the one that delivers power to the head. I'm not sure if anyone may know this but did the 1624 come with an f2 fuse and if it did where would it be?
     
  4. Solventinkjet

    Solventinkjet DIY Printer Fixing Guide

    4,310
    812
    113
    Aug 2, 2011
    Denver, CO
    Check the fuse on the CR board. People tend to forget that one!
     
  5. Austin627

    Austin627 New Member

    3
    0
    1
    Aug 25, 2020
    San Antonio
    SolventinkjetSolventinkjet Sorry forgot to put it has a brand new cr board and the fuse is good.
     
Loading...

Share This Page

 


Loading...