Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

L26500 Yellow printhead keeps clogging

Discussion in 'Hewlett Packard' started by Signmeup_DK, Dec 14, 2013.

  1. Signmeup_DK

    Signmeup_DK New Member

    16
    0
    0
    Mar 15, 2012
    Hi

    Hope you can help.
    My HP L26500 just ran out of garantie after 13 month. and now of curse i get a major problem :|
    Both yellow/black printheads keep clogging up after 2-4 meters of printing.
    I've change the printheads 3 times now, i've cleaned them manually lots of times.
    I've tried to enable HP extra printhead cleaning without much luck.
    All maintenence is done.

    I'm printing on Oracal 3551 with 8 passes normally the quality is fine for the the kind of jobs.

    Any clue?
     

    Attached Files:

    Tags:
  2. GB2

    GB2 Very Active Member

    1,916
    80
    48
    Nov 15, 2005
    Connecticut, USA
    I once had a problem with magenta print heads failing repeatedly but then I got a firmware update, which I think cured the problem. Check to see if you are running the latest firmware. The only other suggestion I can offer is that whenever you install print heads or ink cartridges on HP Latex printers, you should shake, shake, shake them up before installing, that will help to keep things problem free.
     
  3. ProColorGraphics

    ProColorGraphics Very Active Member

    1,434
    88
    48
    Apr 1, 2009
    Minnesota
    Is your printhead cleaning kit working properly?
     
  4. ProColorGraphics

    ProColorGraphics Very Active Member

    1,434
    88
    48
    Apr 1, 2009
    Minnesota
    Also, if it just happened, you might have a bad ink cartridge.
     
  5. Signmeup_DK

    Signmeup_DK New Member

    16
    0
    0
    Mar 15, 2012
    PH Cleaning kit running OK
    I've made a firmware update now.
    The problems has startet suddenly and i just change the yellow inkcartridge.
    Hope that firmware and new ink can do the trick....

    Thanks!
     
  6. Signmeup_DK

    Signmeup_DK New Member

    16
    0
    0
    Mar 15, 2012
    Firmware and new ink didn't do.
    Knowing i resently changed the PH cleaning kit and the fact that it said 30% used i didn't look with my own eyes.
    The picture shows what i found and i do hope replacing it solves my problem.
    Man that could have saved me so much money and time if i just looked instead of relying on what the software told me......

    Thank you so much for pointing it out otherwise i would not have checked!

    (Can't upload the picture, it's tottaly smeared in ink, a wonder it was only yellow and black that caused trouble)
     
Loading...

Share This Page

 


Loading...