Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Laminator seems to be dead, suggestions? Artic Titan 1064wfc

Discussion in 'Installation Equipment & Techniques' started by VicoDrive, Aug 8, 2013.

  1. VicoDrive

    VicoDrive Member

    171
    0
    16
    Apr 25, 2013
    Richmond
    We are using an Artic Titan 1064wfc laminator. Not to familiar with this machine other than laminating with it. We turned it on, it was doing random beeps like when you put your fingers in front of the laser but the laser was clear. It eventually stopped. While I was lining up everything, it started to roll slowly on its own without stopping. I ran to the back of it and turned it off. I cleared out my art and turned it back on, I got a couple beeps again then the lights went out on the machine. We have tried turning it off and on, trying different plugs, different sockets, and nothing seems to be getting this to work again.

    We looked all over it for maybe a master reset button or internal breaker and nothing. We did get it to come on again and beeped a few times before going dead again though. Any thoughts on why its doing this or how to fix it?
     
    Tags:
  2. SignManiac

    SignManiac Major Contributor

    8,494
    37
    48
    Mar 25, 2006
    Mars Florida
    I'd call the manufacturer first
     
Loading...

Share This Page

 


Loading...