Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MAINBOARD FALCON 2 Major Problem

Discussion in 'Mutoh' started by onlyjames, Oct 20, 2009.

  1. onlyjames

    onlyjames The World Is Never Enough

    272
    0
    16
    Nov 1, 2008
    VA
    Hi all, gather around and watch, as a full grown man is beaten down over and over by a printer.

    I installed the new print heads, head cables, new dampers, uploaded new firm ware, All set, and hoping my problems are fixed.

    Well, the FIRST print was exactly the same, SOLID yellow printing, NO black, and Cyan and Magenta are perfect.....oh, and yes, E075 head overcurrent.

    I pulled off the covers to see the main board, and there is a CLEARLY burnt circuit.

    Does anyone know if its possible to fix a mainboard? or does anyone have one for sale?

    I'll be posting up pix soon as I get home. My SD card reader broke too.....not me week, again.

    :thankyou:
     
    Tags:
  2. onlyjames

    onlyjames The World Is Never Enough

    272
    0
    16
    Nov 1, 2008
    VA
    IF anyone has a Falcon 2 Mainboard please let me know, thank you
     
  3. Graphics2u

    Graphics2u Very Active Member

    1,839
    2
    38
    Jan 31, 2007
    Iowa
    Are you sure it's the mainboard? There is another board in there that has big black heat sinks on it that plugs into the mainboard. It's called a head driver board. Or is it just a fuse that is blown?

    I feel for ya!
     
  4. Headhunterx

    Headhunterx Member

    188
    0
    16
    Dec 8, 2007
    Put up some pics I might be able to help you with it I run 2 of these all the time and work on them also.

    Richard
     
  5. onlyjames

    onlyjames The World Is Never Enough

    272
    0
    16
    Nov 1, 2008
    VA
    Im heading home now, I'll post up pix as soon as I get home

    Get ready to see some carnage.....
     
  6. onlyjames

    onlyjames The World Is Never Enough

    272
    0
    16
    Nov 1, 2008
    VA
    Here are some pictures....does anyone have any idea what this part use to run? The pix of the print were taken just befor I pulled the machine apart.....and found the problem. Keep in mind, I cleaned up the problem area some, before it was really charred on one side, almost ash.

    Does not look good.....any suggestions anyone?

    Randy, I have high res pix if they help....just let me know and i"ll send them your way.

    Im interested to see if the tech's know what, where, why and ...um, HOW COME?! :thankyou:
     

    Attached Files:

  7. randya

    randya Very Active Member

    2,060
    3
    38
    Apr 6, 2007
    Arizona
    Looks like the PF or CR connection.....

    Needs a new mainboard at least.
     
  8. onlyjames

    onlyjames The World Is Never Enough

    272
    0
    16
    Nov 1, 2008
    VA
    Im almost done packing up everything, Im sending the main board, CR board and Driver board down to Florida to be repaired.

    Randy, is there anyway you can see if there is a high chance that the print heads were damaged?

    The company wants me to send the print heads as well, but Im nervous about taking them out and sending them down...they are already installed and safe!!

    Thanks all, I will keep updating, and hopefully this will at least help someone else out one day!
     
  9. randya

    randya Very Active Member

    2,060
    3
    38
    Apr 6, 2007
    Arizona
    There is no way to be certain.

    But this looks like the area for one of the motors not the print heads.
     
  10. onlyjames

    onlyjames The World Is Never Enough

    272
    0
    16
    Nov 1, 2008
    VA
    Yeah, I went ahead and sent the two of them also, the "look" fine, with no burn marks ect ect....

    Well, either they are fine, and I actually bought them for no reason because the last two were actually ok...and fixing the mainboard fixes all,

    Or, the two printheads I just bought were burned immediatly...only one way to find out....WAIT!! ha ha, 2 day shipping ($70!!) a few days for fixing/testing, 2 days back, and the big RE-install!!

    This beaten down man will hopefully have some good news soon, in the mean time, my Lil' old rockhopper 38 stands strong!! I will HATE to see that one go, its such a great printer.
     
  11. g1sammons

    g1sammons Member

    53
    0
    0
    Jan 29, 2008
    there is a fella that repairs these in the merchant slassified section
     
  12. onlyjames

    onlyjames The World Is Never Enough

    272
    0
    16
    Nov 1, 2008
    VA
    Yeah, I actually ended up sending the parts to a company in Florida....decent rep from what Ive heard/seen.

    I'll definatly be updating after I get everything back, and if this stuff works again, I will be one happy camper, and this company will have me telling everyone about them!
     
  13. Graphics2u

    Graphics2u Very Active Member

    1,839
    2
    38
    Jan 31, 2007
    Iowa
    Who is it that repairs boards that is a Merchant Member here?
     
  14. onlyjames

    onlyjames The World Is Never Enough

    272
    0
    16
    Nov 1, 2008
    VA
    The only guy I saw was strictly for Mimaki.....
     
  15. Mosh

    Mosh Major Contributor

    5,809
    41
    48
    Oct 19, 2009
    Nerbaska
    You get what you pay for I guess. Falcon? Get a Roland, we have had Rolad equipment for 21 years without a single problem!
     
Loading...

Share This Page

 


Loading...