Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question Mutoh 1204 Random Ink Drops

Discussion in 'Digital Printing' started by Rusty B, Oct 29, 2019.

  1. Rusty B

    Rusty B Member

    31
    3
    8
    Mar 29, 2017
    Tennessee
    I am having a problem with my mutoh 1204 dropping random spots of black ink. It is possibly all colors mixed together I suppose but it always shows up as black. I have run cleanings and also tried to print with the head raised and lowered. It seems if the print head is set to high the random drops are bigger. Any assistance would be greatly appreciated.
     

    Attached Files:

    Tags:
  2. GAC05

    GAC05 Major Contributor

    5,594
    668
    113
    Dec 27, 2005
    Guam USA
    Looks like you have some lint or banner fuzz stuck to the underside of the head. Need to remove cover on the left end and check with a light
    Clean around the edges of the print head(don't swab the nozzles) with a cleaning swab soaked in cleaning solution. Also clean the 2 plastic ramps on either side. Stuff can get stuck up in the gap and sides. They soak up the ink & fling it off when the head slides back and forth.
    If everything is clean then there may be an electrical issue with the head.
    good luck
     
    • Like Like x 2
  3. Rusty B

    Rusty B Member

    31
    3
    8
    Mar 29, 2017
    Tennessee
    Thanks for the info! I will give it a thorough cleaning in the morning and let you know what happens!
     
  4. Rusty B

    Rusty B Member

    31
    3
    8
    Mar 29, 2017
    Tennessee
    I couldn't sleep knowing I had to get it going for tomorrow. You were exactly right. I had buildup on the ramps and wiper. I ordered a new wiper and have the ramps clean as a whistle. I just installed the print head back in May and cleaned it all but I'd say it was due another. This thing is like my oven. Not so self cleaning! Anyway thanks for your help and I'll make sure to give it a thorough cleaning more often now. Wow that was like removing rubber from the fender well of a drag car!
     
  5. GAC05

    GAC05 Major Contributor

    5,594
    668
    113
    Dec 27, 2005
    Guam USA
    Good deal.
    Isn't it around 3am over there right now? Almost time to get up and get to work.......
     
  6. jimmmi

    jimmmi Member

    122
    4
    18
    Sep 13, 2013
    Athens Greece
    As it happens only to black check your damper. Sometimes happens this problem from dampers. Replace it andh a test print.
     
  7. floater302

    floater302 Member

    181
    6
    18
    Aug 29, 2012
    iOWA
    I agree fuzz or lint...I would go as far as maintenance station starting to clog up and not cleaning the head completely, I put a syringe of acetone in my station once a week
     
Loading...

Share This Page

 


Loading...