Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mutoh 1304 printer not printing...

Discussion in 'Mutoh' started by Fast Wraps, Jan 13, 2019.

  1. Fast Wraps

    Fast Wraps New Member

    1
    0
    1
    Jan 12, 2019
    North Carolina
    I have had a this Mutoh 1304 since 2012. I started only printing banners with it in 2018 where sometimes it would sit unused. Long story short, it got to where it would not print at all. After multiple cleanings and charges, still no ink moving through the print head. After attempting multiple head soaks and cleanings, I replaced the print head with a new one. Still the same problem, not printing. Has anyone had the same issue? I replaced the maintenance station on this machine 3 years ago with a genuine Mutoh Replacement. Not sure if this maintenance station needs replacing as well or if the lines are clogged some how or if there is a bad connection or a burnt out circuit on a board.

    Any direction on where to look next would be greatly appreciated!

    Thanks,
    JT
     
    Tags:
Loading...

Share This Page

 


Loading...