Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mutoh 1624 Not printing

Discussion in 'General Signmaking Topics' started by morty87, Jul 11, 2019 at 7:21 PM.

  1. morty87

    morty87 Member

    114
    4
    18
    Feb 17, 2018
    Vancouver
    So as title says. My mutoh 1624 was printing well up until today. It has sat idle for about 3 days and now...nothing. i had an error code this am " E074 CR2 Current" machine beeping. I turned off an went to work. Just came home turned on sounds all good, no error message. I tried a test print and it was just blank. tried a nozzle check nothing. Anyone have any ideas on this?
     
    Tags:
  2. FatCat

    FatCat Very Active Member

    1,883
    119
    63
    Feb 12, 2007
    Columbus, Ohio
    First, to help diagnose your issue, you really need to provide more info. Was the machine printing perfectly before this happened? Had you done any maintenance or changed any parts prior to this? Did ANYTHING change before this occured?

    EO74 CR2 usually means something obstructed the carriage and caused the machine to shut down;
    1. Did you see if the printer possibly hit the edge of the media you were printing? What happened to cause the error?
    2. Check your release plunger to make sure the bracket isn't bent - this is pretty common
    3. Manually run the carriage back and forth the whole length of the rails, make sure there is no excess friction or "rubbing" that occurs
    4. Can't recall if this could also mean an issue with the CR encoder strip - get a flashlight and make sure there is no ink/smudges/fingerprints on the strip and gently glean with a damp swab with a little alcohol.


    As far as your printer not printing at all, you need to determine if the nozzles have somehow dried up, or there is an electrical issue with the head itself.

    Do a head soak using a piece of coffee filter, with the carriage removed from the cap top, cut a piece of filter just slightly larger than the cap top and place on top of the cap top. Soak it good with solvent, then park the head on top of the captop to soak the nozzles. Let it sit for roughly 15-20 minutes, then remove the coffee filter and run a head clean. If you start getting nozzles back, repeat as necessary to get more nozzles back. If nothing prints at all, then you may have an electrical issue with a bad head cable or worst case, some kind of board issue.

    Report back with more details, just too many variables to blindly try to diagnose this...
     
    • Like Like x 1
Loading...

Share This Page

 


Loading...