Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My Versacamm is getting messy

Discussion in 'Roland' started by Drip Dry, Feb 3, 2008.

  1. Drip Dry

    Drip Dry Very Active Member

    1,122
    1
    38
    Aug 11, 2004
    Long island NY
    Last couple of weeks my Versacam is dropping alot of ink droplets on the print. It mostly drops it in the area where the carriage stops and starts it's return to the home station. But it also drops it on the print ( usually ruining the print)
    When I put it into the cleaning mode, I can look up at the heads and everything is clean. When I wipe around the heads with a swab, it comes out dry. ( no ink)

    I've noticed that the sponge is full of ink. I did'nt replace it but I did blot it clean with a paper towel. Not sure if that helped because it started doing it again after a short run. I've changed the wipers.
    I thought I remember the tech told me once that you should be able to pour a small amount of cleaning fluid in the capping stations, and it should drain. Mine dosn't... it just puddles there. ( i'm not sure about this)
    Any ideas
    thanks
    JT
     
    Tags:
  2. cinemasign.grafix

    cinemasign.grafix Member

    469
    0
    16
    Aug 14, 2005
    Is the waste bottle full?Check that the line is not plugged. Have you cleaned the wiper scraper?
     
  3. javila

    javila Active Member

    843
    0
    0
    Jul 30, 2006
    Change the sponge?
     
  4. mark in tx

    mark in tx Very Active Member

    2,081
    0
    36
    Oct 25, 2005
    Harker Heights, Texas
    You need to look at the T-sponge under the misting pad, and the big white pads under the T-sponge.
    Those need to be replaced regularly.

    How old is the machine, and have the capping stations ever been replaced?
    I replace mine every 6-9 months.
     
  5. woolly

    woolly Active Member

    646
    19
    18
    Sep 24, 2007
    Cornwall uk
    possible the pumps are playing up, not sucking the waist away

    woolly
     
  6. Drip Dry

    Drip Dry Very Active Member

    1,122
    1
    38
    Aug 11, 2004
    Long island NY
    The bottle was full. Maybe the line is plugged..I'll check
    The wipers are new.

    I'll order and replace

    Mark, Can you elaborate on this... Is the t-sponge that is referred to in the above post? what is the misting pad?

    Machine is 2 1/2 years old. Are capping stations something I should be able to do, or do I need a tech ?
     
  7. Former member

    Former member Member

    484
    1
    0
    Mar 24, 2006
    My guess is that its a bad pump. There's a newly designed pump for these printers. ask your tech about it.
     
  8. threeputt

    threeputt Very Active Member

    3,389
    1
    38
    Mar 10, 2006
    washington state

    Don't know about that. I've got the new pumps installed and mine will do that occasionally. Usually the maintenance cleaning is all it takes. I always blot the sponge to take up excess ink, but I think the real problem could stem from threads or little wisps of banner scrim get stuck to the print heads, and then begin to drip/drop when they saturate.

    Usually this happens after running a bunch of banners. I usually just maintenance the machine and it's a fix.
     
  9. Drip Dry

    Drip Dry Very Active Member

    1,122
    1
    38
    Aug 11, 2004
    Long island NY
    Thanks everyone.
    Changed the sponge and t-sponge
    Also found the wiper scraper was broken. The half that wasn't broken was all crudded up (looked and felt like steel wool was growing from the scraper)
    Thanks again
    JT
     
  10. Mac34

    Mac34 Member

    135
    0
    0
    Mar 11, 2007
    They replaced my pump on my SP300 for free. I guess there were issues with the older one's, and they upgraded it for me. I've had droppage issues from time to time, but running a clean or two usually takes care of the problem.
     
Loading...

Share This Page

 


Loading...