Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Newer printer with an older Flexi??

Discussion in 'RIP Software & Color Management' started by Scott Reynolds, Jul 22, 2012.

  1. Scott Reynolds

    Scott Reynolds Active Member

    828
    0
    0
    Feb 5, 2005
    I have Flexi 7.5.5 and if I get an HP 9000s, how the heck do I get the driver and ICC's for Flexi? I looked at flexi's web site and there is nothing. Their site is close to useless IMO.

    Can I email them to add it to my 7.5.5 or are they going to tell me to upgrade? I know, I know, "pay the $1400 you cheap a$$".

    On a different subject, I found my old copy of PosterShop 7 and the dongle is missing! :banghead:
     
    Tags:
  2. Sign-Man Signs

    Sign-Man Signs Member

    284
    0
    0
    Oct 5, 2010
    Scott I use Flexi 7.0. I also use Flexi Starter. When you open both, the Flexi Starter will allow 7.0 to cut, rip etc. Why? I have no idea, but it works for me. Flexi Starter is about $100.00 on Ebay. Good luck. There are no drivers to be found for the 7.0, 7.5.5.
     
  3. FrankW

    FrankW Active Member

    982
    36
    28
    Oct 19, 2008
    Switzerland
    They don't add custom drivers on such old versions, you should need to upgrade to a version which supports the 9000s (it seems to be that Flexi 8 does).

    Postershop Dongle: because of the Dongle is the proof of licence, you will need to buy a new licence to use the software.
     
  4. SightLine

    SightLine Very Active Member

    Going to have to upgrade to a RIP at least as new as the printer.... The companies that make the RIP like Scanvec, Onyx, etc also have to custom write drivers for each supported machine. They only do so for machines that are available when the current version is released and maybe add new machines while the current version is still out and supported. 7.5 is is nearing 10 years old and was released in 2003 http://www.signindustry.com/pressrelease/2003/2003-10-13-Scanvec.php3

    I cannot say that I'd blame them or be mad that they no longer support or write drivers for a program that old. Lowest cost option (which is what I'd probably do) would be to find a used copy of 8.5/8.6 which was the first version truly and fully supported on 64 bit versions of Windows plus has the support for that HP 9000. That or pay the big bucks and upgrade to 10.5... We run 8.6v2, I did just check and the HP 9000s is definitley in there as a setup you can add.
     
  5. CS-SignSupply-TT

    CS-SignSupply-TT Very Active Member

    1,541
    1
    0
    May 31, 2011
    Flexi 7.5.5???

    Scott, is this Flexi Starter, Sign, Expert, or Pro?
     
  6. Scott Reynolds

    Scott Reynolds Active Member

    828
    0
    0
    Feb 5, 2005
    Ya, I know. Hints hitting head on wall. :banghead:

    I must have upgraded the last time just days before v8 came out because I swear it was late 05 when I upgraded last time. Maybe late 04. Damnn time flys. Thanks for the info.

    Been a Pro user since 01'.

    Im going to upgrade anyway, just in the market for a printer and was wondering if I could test print with my Flexi when "test driving" used printers.

    Thanks, Scott
     
Loading...

Share This Page

 


Loading...