Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC-600 - photo needed

Discussion in 'Roland' started by stevelv, Nov 6, 2006.

  1. stevelv

    stevelv Member

    44
    0
    0
    Oct 14, 2006
    Does anyone have a PC-600 which does not have problems picking up and replacing print catridges?

    If so could you send or post a close up picture of the left and right hand side of the closed printer cover where the cover that holds the cartridges meets the magnetic stops?

    Ours was shipped by UPS who seem to have managed to either drop or manhandle it and the cover was pushed in on one side - we bent the magnet holders back into place and it's fine on positions 1-3 but with 4 it's hit or miss and with 5 and 6 it almost never picks and returns cleanly. Spoke to Roland (what a waste of time) and they want it shipped to Oregon for a service but it was the shipping that caused the damn problem in the first place!!

    So a photo will at least let us duplicate the same cover position as someone elses.

    Many thanks

    Steve
     
    Tags:
  2. mladams7259

    mladams7259 Very Active Member

    1,319
    0
    0
    Sep 7, 2006
    how odd, i bought a pc-60 and UPS dropped it and bent the end in that has the parrallel and serial connections on mine also. I have trouble with 2 and 5 not picking up the cartridges. I took it apart and bent the whole casing back straight. That seemed to help alot. It only does it occasionally now. But the bad thing is that they damaged the parrallel port and it will not work at all. Only the rs232 port will work. I live in Mississippi and Roland wanted me to ship mine off to Atlanta Georgia. Not gonna happen. To expensive and as you said, shipping is the cause of the problem anyway. BTW, I had to order a new head for mine today! $540 !!! And thats with me installing! Any tips or tricks would be of great help! Thanks!
     
  3. Hollywood

    Hollywood Member

    357
    0
    0
    Aug 24, 2006
    UPS did'nt cover it because they did it?
     
  4. mladams7259

    mladams7259 Very Active Member

    1,319
    0
    0
    Sep 7, 2006
    As far as my PC-60, Im not going into that story (would only **** me off again) LOL. But the answer is no, and that sux
     
  5. stevelv

    stevelv Member

    44
    0
    0
    Oct 14, 2006
    UPS only cover complete loss - they will always blame in transit damage on insufficient or improper packaging.
     
Loading...

Share This Page

 


Loading...