Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

printhead will not print!!! help!

Discussion in 'Roland' started by banner, Apr 6, 2011.

  1. banner

    banner Member

    29
    0
    0
    Feb 11, 2011
    head of cyan and magenta will not print, I've checked the sealing caps are ok. what do I do?

    My print : XC-540 soljet proIII
     
    Last edited: Apr 6, 2011
    Tags:
  2. artbot

    artbot Very Active Member

    3,164
    12
    38
    Feb 18, 2010
    Houston TX
    is there latent ink in the cap? first diagnose if you are getting a good seal at that cap. not sure of your pump/cap configuration, but, also you need to check if you have a clogged pump to that cap. common clog points are directly beneath the cap, within the cap itself, unions where cap tubes meet pump tubes, inside the pump, at the very tip end of the drain line.

    to diagnose if you have a clogged pump:

    you can do a simple pump tube swap to see if a different pump line magically cures the issue, if so, you might need to either flush that pump line or replace the tube inside.

    it it's not pump/vacuum oriented, then do a data swap on your printer. but check first with someone that is familiar with the layout of your particular machine. data swaps are completely safe if done correctly, and can fry slider boards if done wrong. this would be most suspect if you are seeing ink flow to your cap tops and through the pump but do not get a print. data issues can be damaged data ribbon, bad head, bad board, fuses etc.
     
  3. banner

    banner Member

    29
    0
    0
    Feb 11, 2011
    My printer is a XC 540 proIII

    I swapped the seal (cap), it still does not print in group A, cyan and magenta.
    I swapped the Catucha ink.

    beyond the pump may be the dumper?
     
  4. flyinhawaiian968

    flyinhawaiian968 Member

    445
    0
    16
    Mar 12, 2008
    I know this is an old thread, but for those searching for two heads out on an xc-540, there's a fuse on the main head board that controls power to the CM heads, one for the YK heads and a third fuse for the LcLm heads, just went through this on my machine over the weekend.

    Good luck in finding one of them in an electronic parts store, nobody, and I mean NOBODY! In all of the greater Portland area, no electronic parts store has them in stock.

    Just an fyi, I have a dead black printhead which is causing that fuse to blow, hopefully this wasn't the case for the o.p...

    Chris
     

    Attached Files:

Loading...

Share This Page

 


Loading...