Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

problem w/ window perf install

Discussion in 'General Chit-Chat' started by night eagle, Jun 25, 2020.

  1. night eagle

    night eagle Active Member

    611
    27
    28
    Mar 9, 2009
    Crowley tx
    i double pass printed this, and used a felt squeege to apply.....ive never seen this, but it looks like dust, or like maybe the sqeege fell apart and the holes scraped the edge of the squeege....ive installed several dozen of these and never seen this....any ideas?
     

    Attached Files:

    Tags:
  2. RICHARD SIMMONS

    RICHARD SIMMONS Member

    108
    11
    18
    Jul 12, 2019
    Panama city, Panama
    Maybe it's time to change the felt squeege !!
     
  3. Lindsey

    Lindsey Not A New Member

    100
    27
    28
    Jan 17, 2013
    Canada
    Is it laminated? If it's not, it's probably fuzzies from the felt squeegee.
     
    • Agree Agree x 1
  4. ewded

    ewded Active Member

    504
    92
    28
    Aug 28, 2017
    UK
    Looks like paint was scraped off, when installing these I never press hard on the squegee, in fact I barely touch it, it'll stick anyway.
     
  5. 2B

    2B Very Active Member

    3,049
    395
    83
    May 5, 2011
    TX
    how did you prep the glass?
    Looks like there was debris on the glass before install

    we have taken to "scraping" glass with a wide edge razor.
    even "lint-free" towels leave debris
     
    • Agree Agree x 2
Loading...

Share This Page

 


Loading...