Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help SP 540i tubes blocked?

Discussion in 'General Signmaking Topics' started by Shirley Louise, Aug 28, 2018.

  1. Shirley Louise

    Shirley Louise New Member

    3
    0
    1
    Aug 16, 2018
    Seychelles
    Experiencing some real difficulties with the Versacamm SP 540i as the print test only shows the yellow and magenta whereas the cyan and black are not coming through at all. Unable to print anything and am unable to understand what could be causing the problem except for the tubes going to the head that looks dried up or blocked??? Any ideas
     
    Tags:
  2. player

    player Major Contributor

    4,721
    141
    63
    Apr 24, 2006
    Toronto
    Could be lots of things. Could be the fuse out on the main board. Could be the dampers. Could be the cap is old and not sealing and the head is dried. Could be the pump is not pulling hard enough.

    Do you know how to do a head soak? That is what I would try first.

    Did anything happen to the printer before it stopped working like a head strike?

    Search head soak and try that for a day first. Be sure to clamp off the hose so the cleaner stays in the cap.

    Be sure to update this post as to what is going on...
     
  3. Shirley Louise

    Shirley Louise New Member

    3
    0
    1
    Aug 16, 2018
    Seychelles
    Thanks for the advice. Will attempt a head soak and update.
     
  4. player

    player Major Contributor

    4,721
    141
    63
    Apr 24, 2006
    Toronto
    If you haven't changed the caps for some time, you should order some new Roland OEM caps and change them.
     
Loading...

Share This Page

 


Loading...