Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sp300v pump unit

Discussion in 'Roland' started by hailo, Jul 5, 2012.

  1. hailo

    hailo Member

    41
    0
    0
    Oct 21, 2005
    Hello:
    When I attempt to do a head cleaning, I hear a horrid noise coming from the pump unit. Any advice on that, as far as troubleshooting? Or how to determine that I need a new one? Why does this happen? Any help would be appreciated.
     
    Tags:
  2. hailo

    hailo Member

    41
    0
    0
    Oct 21, 2005
    something seems to be leaking in there...right under the cap tops...
     
  3. CS-SignSupply

    CS-SignSupply Very Active Member

    Take off the front covers and take a look. With a flashlight, you should be able to see if and where it is leaking.

    Post a picture or two here for all to see and I bet you will get plenty of assistance. Even this late on the East Coast.
     
  4. hailo

    hailo Member

    41
    0
    0
    Oct 21, 2005
    I had bought some cap tops earlier this year and never put them in. I just put them in and it is looking good with no leaks...could it have been a clogged hose?
     
  5. CS-SignSupply

    CS-SignSupply Very Active Member

    Very well could have been a clogged captop/hose... I have also seen the hose/tube come disconnected from the bottom of the captop on most third-party caps therefore causing a leak.
     
  6. premiercolour

    premiercolour Very Active Member

    We are not too far away from Riverside CA. We can send a tech to take a look. Pm for more info.
     
  7. Dakotagrafx

    Dakotagrafx Member

    182
    0
    16
    Jan 6, 2011
    Michigan
    I had a similar experience, I had pinched the hose in the threads of the waste ink container - blew off the caps from the extra ink outlets on the pump and made a noise and a big mess
     
  8. Fatboy

    Fatboy Very Active Member

    Is the noise gone?
     
Loading...

Share This Page

 


Loading...