Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help Question Summa S2 75T Pinch roller sensors not working

Discussion in 'Summa' started by dsd7, Apr 17, 2019.

  1. dsd7

    dsd7 New Member

    24
    0
    1
    Feb 23, 2012
    Utah
    Hey guys,

    I just purchased a brand new Summa S2 75T about 2 months ago. Ever since Friday it no longer reads the pinch roller positions and is not usable.
    I have 2+ rolls of laminated material with summas registration marks needing to be cut and another 8 rolls to cut. I'm loosing my patience!

    Things I have already done:
    1. Called tech support: getting the run-around and it's EOD Wednesday with no contact. or solution. I have called many many times.
    2. Cleaned / blew off the sensor.
    3. put machine into sensor mode to verify sensor is not working. It says it's covered when it's not.
    4. Cleaned sensor again.
    5. Reset to factory defaults.
    6. Searched online for summa parts (can't find anything?)


    The last thing I heard was on Friday, this is what a Summa tech said,

    "This points to a sensor being fine and possible issue with main PCB. RESET MAIN PCB TO FACTORY"

    How do i do this?
    or
    Does anyone know where to purchase summa replacement parts?
     
    Last edited: Apr 17, 2019
  2. FrankW

    FrankW Very Active Member

    1,324
    135
    63
    Oct 19, 2008
    Germany
    Every factory configuration of any plotter since around 2009 or so is downloadable through the Summa Website:

    https://www.summa.eu/en/vinyl-cutter-downloads

    At the end of this site, you find a possibility to input the serial number of your device. Put it in and klick the magnifying glass, and a download link will appear. Download the file and restore it to the cutter through Summa Cutter Control. Have found out that sometimes the cutter needs additional calibration, but if the machine is only a few months old, you should not run into big trouble.

    But not shure if this will help. Could be that a piece of vinyl stucks in the sensor (it is difficult to reach behind the cutting head). Could happen very seldom that the sensor is mechanically broken.
     
    • Like Like x 2
  3. dsd7

    dsd7 New Member

    24
    0
    1
    Feb 23, 2012
    Utah
    Thank you FrankW! I really appreciate it!

    I found the file and downloaded it. However, I am getting an error while using cutter control.

    I get this error 90% of the time (it's been an issue since day 1)
    "Access Violation at address 005321A8 in module "CutterControl.exe". Read of address 00CCb000"

    I am not able to connect to the printer. Any ideas?


    EDIT: This same error comes up on 2 different computers, using both USB and ETHERNET connections
     

    Attached Files:

    Last edited: Apr 18, 2019
  4. FrankW

    FrankW Very Active Member

    1,324
    135
    63
    Oct 19, 2008
    Germany
    Have no idea about that error. Could you try to open Summa Cutter Control in Administrator mode (right click on the app icon)? And do a re-install?
     
  5. FrankW

    FrankW Very Active Member

    1,324
    135
    63
    Oct 19, 2008
    Germany
    Unfortunately I had sensor trouble with a Summa DC4 a few weeks ago ... in this case we suspect a mainboard damage. To check that, could you have a look if other sensors are working correctly? The media sensors are easy to check.
     
  6. dsd7

    dsd7 New Member

    24
    0
    1
    Feb 23, 2012
    Utah
    I have tried that. No go. After finally speaking with tech support they said the machine needs to complete setup or it won't connect. Got it to work so long as media is loaded when it's turned on.
     
  7. dsd7

    dsd7 New Member

    24
    0
    1
    Feb 23, 2012
    Utah
    I have put it into service mode and sensors check out fine. Pinch roller sensor (CAM) isn't working. After finally speaking to tech support, pinch roller sensor needs replacing. I'm waiting on Grimco to service the unit which the tech couldn't give me an answer as to how soon that may happen...


    Would anyone know where to purchase summa parts? I can use the Graphtec for the time being but it can't keep up with the workload.
    I'm very familiar with servicing the Graphtec. The Summa looks very similar. I am considering doing it myself.
     
    Last edited: Apr 18, 2019
Loading...

Share This Page

 


Loading...