Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help SummaCut D120

Discussion in 'Summa' started by Dan Thomas, Apr 5, 2020.

  1. Dan Thomas

    Dan Thomas New Member

    22
    0
    1
    May 6, 2017
    Calgary Alberta, Canada
    Hello, Have shaking blade holder while cutting, when not on moves smoothly all rollers and belts, removed blade holder and ran test print and still shakes while cutting, eliminates blade holder cut strip or blade, motor maybe? cuts fine , throwing no errors . this is the older grey D120. running windows 7 pro 64 bit , flexi 10 and gerber omega 6.5 CP summa cutter control working like a champ as it should. when i do an actual cut it is slightly perforated but still cuts
     
    Tags:
  2. FrankW

    FrankW Very Active Member

    1,324
    135
    63
    Oct 19, 2008
    Germany
    Sometimes, with a series of cutting heads, the clamp who holds the blade holder at the cutting head could break. It does not fall away, but a little crack could lead to a shaking blade holder. But you will see that in the cutting quality too, but you said that it cuts fine.

    If there is no crack, and the blade holder stucks without wiggling in the clamp, then it could be that the rollers which guides the cutting head are dirty.

    For any other suggestion, a cutting sample or video is needed.
     
    • Like Like x 1
    • Agree Agree x 1
  3. Dan Thomas

    Dan Thomas New Member

    22
    0
    1
    May 6, 2017
    Calgary Alberta, Canada
    Your Right! needed to clean the rollers and glide that guides the cutting head! Working great Again
    Thank you So Much
     
Loading...

Share This Page

 


Loading...