Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Symptoms of pump going bad on SP-300v?

Discussion in 'Roland' started by GRIMREAPER, Aug 20, 2012.

  1. GRIMREAPER

    GRIMREAPER Member

    43
    0
    6
    Aug 10, 2009
    What are the symptoms of a pump going bad on a SP-300V? I have a problem that I syphon the ink out through the dampers and my machine will print fine for a few then ink fades and stops printing. Dampers, caps and wipers are all new and have just been installed and I'm wondering if it may be the pump. Thanks.
     
    Tags:
  2. CS-SignSupply-TT

    CS-SignSupply-TT Very Active Member

    1,541
    1
    0
    May 31, 2011
    Hey, try giving Keith Faulkner and his folks at www.splashofcolor.com a call. They should be able to help you diagnose and offer repair suggestions
     
  3. CS-SignSupply

    CS-SignSupply Very Active Member

    If your prints are fading out of color during print, the cause usually lies within the damper(s) or printhead manifold (cracked and letting air into the system)

    The pumps in the Roland machines now are very durable and long lasting. The Old style pumps with white tubing will wear out relatively fast.

    What inks are in the machine and did you replace the dampers/captops with OEM or aftermarket parts?
     
  4. GRIMREAPER

    GRIMREAPER Member

    43
    0
    6
    Aug 10, 2009
    Well I just replaced the caps, dampers and wipers with OEM ones and problem is still there. The inks are Ecosol Max but at one point when it started failing it was on Solaris. Switched inks to factory Ecosol Max but to no avail.
     
  5. CS-SignSupply

    CS-SignSupply Very Active Member

    Your test print is good? and when printing, color drops out? Can you tell which color(s)?

    Can you send me, or post here, a picture of your test print, captops and pump?

    Ink starvation is a common issue with broken or fractured printhead manifold or faulty dampers.

    About the only symptom of a bad pump I have seen is busted internal ink line and leaking. Or completely clogged lines.
     
  6. anozira02

    anozira02 Member

    442
    1
    18
    Mar 23, 2009
    Prescott, arizona
    It is also possible that the clear tube on your capping station is clogged, also check the waste tube, if you do a cpl. of head cleaning and you see in coming out of waste tube, than the pump is ok..
     
  7. GRIMREAPER

    GRIMREAPER Member

    43
    0
    6
    Aug 10, 2009
    Did the check and ink is cocming out of the waste tube. Machine worked for about 18 days perfectly fine after syphoning from the pump area. It stopped printing today after the weekend of sitting but a quick syphon and it's pringing again. Just had a little color contamination in the yellow but did some solid color pringting and it's gone. I have no idea why it stops printing after some time onw it's own.
     
  8. Robert M

    Robert M Very Active Member

    1,308
    6
    38
    Jan 23, 2007
    colorado
    Those pumps

    Roland had a recall on those pumps back in the day, if you have the old style pump (has white tubes) it could be the problem. You can get a new pump and the adapter kit or just put a Mimaki JV3 pump in there. The Mimaki pump is better made and will last longer.

    I sell them at www.solventinkjet.com if you need one
     
Loading...

Share This Page

 


Loading...