Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Where are the fuses on Valuejet?

Discussion in 'Mutoh' started by Mr. T, Oct 29, 2008.

  1. Mr. T

    Mr. T Member

    93
    0
    6
    Oct 28, 2008
    north tonawanda ny
    I have a Mutoh Valuejet 1204. My machine would not power up a few weeks ago and the service tech took the fuses out and put the same ones back in and it fired up. Now the same problem occured and I cannot find the fuses. Any ideas?
    Thanks,
    Tracy
     
    Tags:
  2. signage

    signage Major Contributor

    10,621
    271
    83
    Oct 5, 2005
    Penn
    I would call the tech back and have them repair the unit, most fused do not just blow, either you are doing something wrong or the machine has a problem causing the fuses to blow!
     
  3. Compilla

    Compilla Active Member

    733
    0
    0
    Jul 21, 2005
    Ditto
     
  4. I have seen this happen many times here in Florida. Unplug the machine and let it sit 5 minutes. Not 1 minute. It will fire back up.
     
  5. sarge

    sarge Active Member

    923
    0
    0
    Oct 18, 2008
    maybe it is a slow blow fuze . but i agree .. something is amiss .. maybe a burnt transistor on the power supply .. i dont have your machine .. but my summa has a both an internal and external fuze .. the internal fuze might be on the power supply .. it is where i would look .. and do you power down your unit when not in use? .. just a thought
     
  6. MacDaddy

    MacDaddy Member

    497
    0
    0
    Mar 29, 2008
    Remove the back cover, the fuses are located on the right end as looking at it from behind. The are near where the AC Power Cord connects to the machine.
     
  7. Mr. T

    Mr. T Member

    93
    0
    6
    Oct 28, 2008
    north tonawanda ny
    Fuses

    Thanks Folks,
    I unplugged the unit for about 15 minutes and whala she fired up. Has been fine all day. Very strange!!!
    Thanks,
    Tracy
     
Loading...

Share This Page

 


Loading...