Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help Who's familiar with Epson Surecolor S50670 ink system?

Discussion in 'Epson' started by Dtron10, Dec 20, 2019.

  1. Dtron10

    Dtron10 New Member

    14
    0
    1
    Sep 19, 2017
    New York
    Hello,
    I'm in need of some help...who's familiar with Epson Surecolor S50670 ink system? I'm having an error message pop up saying an ink cartdridge (black) is unlocked, when it's clearly locked. This is all that comes up on my screen and I can't get past it. It finally got past that screen now its saying the white cartdridge needs to be locked or something. I'm wondering if the lock levers are just shot? I'm hoping I can make a fix without a servicing. Thanks for your time.
     

    Attached Files:

  2. unclebun

    unclebun Very Active Member

    When I've had that happen, I've had to either remove all the cartridges one by one and push them in and lock, or shut off the printer and then turn it back on.
     
    • Like Like x 1
  3. SignMeUpGraphics

    SignMeUpGraphics Moderator

    1,095
    210
    63
    Apr 11, 2012
    Australia
    Are we looking at the same photo here? It's asking you to perform maintenance on the white tank, which involves removing the tank, shaking for 10-15 secs and re-installing.
    Have you actually done that part yet? Your post doesn't seem to indicate.
     
  4. Dtron10

    Dtron10 New Member

    14
    0
    1
    Sep 19, 2017
    New York
    Yes, I've tried removing all the cartdridges one by one and push and lock them back in. Even tried swapping all the colors from one side to the other. And restarting and unplugging.
     
  5. Dtron10

    Dtron10 New Member

    14
    0
    1
    Sep 19, 2017
    New York
    I apologize for lack of information. I typed it up real quick on the run. So the first error/warning was I thought in regards to the black ink cartdridge because it wasn't reading that it was locked and even a couple others as you can see from the photo other then the cyan on the left side. Then somehow it randomly got past that screen the other night and it has the white warning / maintenance message. And yes I've tried doing the usual shaking of the white cartdridges and still can't get past that screen. Its all happening on the left side. Hopefully the pictures kind of help out explaining. 20191220_203259.jpg 20191220_203547.jpg 20191220_203642.jpg 20191220_203759.jpg
     
  6. SignMeUpGraphics

    SignMeUpGraphics Moderator

    1,095
    210
    63
    Apr 11, 2012
    Australia
    Okay thanks for the additional info.

    For the first issue, there is an absolutely tiny piece of plastic which the printer uses to determine if the latch is closed or not. It's like a $1 part, but rather difficult to get to (entire control panel needs to come out).
    We've replaced one after the printer not seeing the grey tank being locked into place. To be honest, once in the area the problem was evident.. not broken, just askew. A tiny poke with a screwdriver would have sorted it, but we put the new part in anyway.
    You may be able to get around it by repeatedly opening and closing the latch quickly a couple of times (but not forceful). The tolerances on the part seem to be quite wide so I could see why it dislodged.
    Please bear in mind this was on an S80600, but I would assume parts would be near identical to your model.

    Unsure about the WH maintenance happening now though. I'd try removing the tank, rebooting the printer then re-installing. If you have a spare WH tank, I'd also try inserting that to see if it gets around the warning for the time being.
     
    • Informative Informative x 1
  7. Dtron10

    Dtron10 New Member

    14
    0
    1
    Sep 19, 2017
    New York
    Ok that is really helpful, thank you for that. I understand what your saying about that possibly being askew, or possibly broken. I feel like something back there isn't reading that it's actually locked in. Like I said for a bit it wasn't reading almost all the CMYK on the left other then the cyan. So I'm curious if it is something back there screwing with all the sensors for the left side locking device. Unfortunately I don't have enough knowledge of taking the whole front panel off myself, I could probably google it. But that definitely gives me something to go on. Or hopefully like you said with repeatedly opening and closing the latch and maybe falls in place. But I've definitely been trying similar to that for the last few days and not great luck. Thanks again for the info!
     
  8. SignMeUpGraphics

    SignMeUpGraphics Moderator

    1,095
    210
    63
    Apr 11, 2012
    Australia
    If it's the same as the 80600, you can't get to this piece from the front. I'll take a photo tomorrow and give you an idea on how to get in from the top. If you don't hear back, just send me a PM on here and it'll remind me.
     
  9. Moham

    Moham New Member

    3
    0
    1
    Feb 13, 2020
    United Kingdom
    Hi
    Can you please tell me how you got in from the top to fix this issue, I have the same issue come up on 50600 black ink cart, thanks
     
  10. SignMeUpGraphics

    SignMeUpGraphics Moderator

    1,095
    210
    63
    Apr 11, 2012
    Australia
    There is a service door on the right hand side of the machine (same side the power plugs go) that needs to be removed. Then you need an insanely long (30cm+) screwdriver to unlock the heads, then you need to remove the media clamp handle at the top, then remove the control panel, then finally the top panel.
     
Loading...

Share This Page

 


Loading...