Welcome To Signs101.com: Largest Forum for Signmaking Professionals

Signs101.com: Largest Forum for Signmaking Professionals is the LARGEST online community & discussion forum for professional sign-makers and graphic designers.

 


  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please help. Installed new print head

Discussion in 'Mutoh' started by midnightmadman, Feb 16, 2019.

  1. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Please help. I purchased a print head from someone that was used, but they assured me it had a 100% nozzle check. I pulled ink lightly through the maintenance station to full it. When I go to do a nozzle check I am getting 0 ink no nozzles printing. Am I missing a step? I think I remember someone saying there is a procedure that might need to be done on the machine when it gets a different head installed?
     
    Tags:
  2. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Is it 100% necessary to put a new head rank number in?
     
  3. Umca

    Umca Member

    161
    10
    18
    Sep 4, 2015
    UA
    It is not 100% necessary, but extremaly recommended. Prithead will work with wrong head rank but in wrong mode.
     
  4. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Thanks
    I’m getting nothing at all
    Maintenance station seems fine
    I get ink out waste line when doing a cleaning and can also pull all colors
    Now I just have nothing from head
    The old head did have nozzles printing
     
  5. DTP2

    DTP2 New Member

    20
    1
    3
    Jan 12, 2018
    Netherlands
    Clean cappings, set carriage to low and do a little charge. If that is not helping, do a second little charge. If you replace your heads, the ink retracts and you need to bring this back to the heads first and slightly pulling this from under the capping station is not enough in most cases. Every print head has a different voltage. Setting the correct head rank tells the printer what head is placed with what voltage and compensates for that. You are spending quite some money and time on a new head so do it as it just takes 5 extra minutes of your time.
     
  6. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Thank you
    I’m going to search on how to change the head rank
    Keeping fingers crossed
    I’m hoping I have the right head
    The manifold he sent with it was made out of the wrong plastic and seems to have melted and the tips broke off in the dampers
    I just pulled them out and now need to put my old manifold on the new head
    Uggg
     
  7. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    If I’m pulling ink from under the capping station doesn’t that mean the head should be full because it’s flowing through it?
     
  8. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    I tried to enter the new head rank number from the sticker off the manifold
    The problem is I the second 2/3 line I can not enter the values it shows like U
     

    Attached Files:

  9. Umca

    Umca Member

    161
    10
    18
    Sep 4, 2015
    UA
    It is not Mutoh format of head rank. Heads from Mutoh has 24 symbols on the rank,
     
  10. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Yes he sent me all the wrong stuff. :(
    Is there any way to trick the head To work with mutoh?
     
  11. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Is it safe to assume this print head will never work with my 1204?
    Or is there any possible way before I return it
     
  12. Solventinkjet

    Solventinkjet DIY Printer Fixing Guide

    4,303
    810
    113
    Aug 2, 2011
    Denver, CO
    You probably just blew a fuse on the main board. The machine holds a charge even when unplugged and needs to be discharged before working on it.

    Also just a note, if head ranks did anything important I would have 100's of machines in the field failing right now. I work on all the top brands that use Epson based heads and have never seen a head rank change the function of the printer whatsoever and I have worked on countless printers.
     
    • Disagree Disagree x 1
    • Agree Agree x 1
  13. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Thanks
    So even though this is not the correct head for mutoh machine you feel it should be working ? And if the fuse is blow to I just check it for continuity? Or is there more to it
    It is soldered In from what I can see
     
  14. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    This is the head
     

    Attached Files:

  15. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    I just tested both of these fuses for continuity and they are good
    What else could it be, could the cables cause it to not fire at all?
     

    Attached Files:

  16. Solventinkjet

    Solventinkjet DIY Printer Fixing Guide

    4,303
    810
    113
    Aug 2, 2011
    Denver, CO
    There is another fuse to the right of that area that is a 750mA fuse. That is the one you want to test,
     
  17. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    I’m only seeing those two
     

    Attached Files:

  18. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Do you see it in this image at all ?
     

    Attached Files:

  19. Solventinkjet

    Solventinkjet DIY Printer Fixing Guide

    4,303
    810
    113
    Aug 2, 2011
    Denver, CO
    In that picture it is covered by the black heat sink. It is towards the edge of the board and is lower profile than the other fuses. It's labeled F2 or F3 I can never remember.
     
  20. midnightmadman

    midnightmadman Active Member

    585
    4
    18
    Aug 4, 2008
    Westtown, NY
    Thanks
    Do I need to remove the heat sink to get to it
    Or remove the whole board???
     
Loading...

Share This Page

 


Loading...